Paramètrage glpi 10.0 RC2

Bonjour,
Je rencontre plusieurs problème avec GLPI 10. Parmi ces problèmes j’ai celui des migrations !


Systématiquement quand j’utilise la commande php console pour exécuter les migration j’ai le message suivant « Warning: Missing required intl PHP extension in C:\inetpub\Glpi\src\Session.php on line 680 »

Je suis allé voir dans le fichier Session.php, l’extension intl est bien activée.
Par contre je ne comprends pas la ligne du dessous « The version of database is not compatble with version of the installed files. An update is necessary ». ça voudrait dire que ma base MySQL est trop ancienne par rapport à glpi 10 ??

Merci d’avance pour votre aide

SNSM

Bonjour,

Quelle version de MySQL / MariaDB avez vous ?

Romain

Bonjour,
Désolé pour le retard.
la version de MySQL est 8.028. mis à jour il y a quelques temps

Bonjour,

Pour essayer de résoudre, ce problème voici un lien qui pourrait vous aider : https://tic.gal/en/access-to-timezone-database-mysql-is-not-allowed/

Je ne sais pas ce que l’équipe de dev de GLPI à derrière la tête, mais ca devient n’importe quoi leur mise à jour et leur configuration.

J’ai effectué cette manipulation, la mise à jour des tables a pris 1h pour 15Go, sur un serveur Windows on peut quasiment multiplier le temps par 2.

Bon courage

Bonjour,

Merci mais je suis sous Windows server 2019, IIS, GLPI10 RC2, PHP 8.1.3 et MySQL 8.0.28.